[win10][java 1.8.0_171][WesterosCraft Launcher]

Discussion in 'Support' started by _Benja, Jul 13, 2018 at 2:15 AM.

Tags:
  1. _Benja

    _Benja Builder

    Hello... I have recently tried to log into the WesterosCraft Launcher (I recently installed it on my new computer), and I have been given the following error:

    Error: Could not create the Java Virtual Machine.
    Error: A fatal exception has occurred. Program will exit.


    I have edited my minimum / maximum memory to 4G and also 6G and I get the same error. I don't know if I'm doing that part right, so if someone knows how to properly edit the min/max memory please let me know.

    Also, if it matters, I have 8gb of RAM on my computer currently.

    Thank you!
     
  2. _Benja

    _Benja Builder

    The spoiler text with my log didn't go through, so here it is.

    EDIT: It won't let me post the logs, so here's the end bit of them...

    Invalid initial heap size: -Xms4G

    The specified size exceeds the maximum representable size.

    [01:11:07.478] Minecraft process terminated
     
  3. _Fede13_

    _Fede13_ Nobuild

    I had the same problem, but i managed to solve it by selecting 3G for both maximum and minimum memory.
    Hope you find that useful
     
  4. _Benja

    _Benja Builder

    Okay, so I made sure my java was up to date and 64-bit, my max is also equal / greater than my min...

    However, I now have an error that says: Too small initial heap
     
  5. Could you post a screenshot of your settings?
     
  6. _Benja

    _Benja Builder

    upload_2018-7-15_0-31-3.png
     
  7. You are using 32-bit Java. You need 64-bit.